Re: [PATCH 4/5] adt7473: Check inputs from sysfs writes

From: Jean Delvare
Date: Fri Nov 07 2008 - 15:35:37 EST


On Fri, 7 Nov 2008 11:20:40 -0800, Andrew Morton wrote:
> On Fri, 07 Nov 2008 10:56:41 -0800
> "Darrick J. Wong" <djwong@xxxxxxxxxx> wrote:
>
> > +#define ROUND_DIV(x, divisor) (((x) + ((divisor) / 2)) / (divisor))
>
> It might make sense to rename this to ROUND_CLOSEST, fix the
> double-evaluation and whap it into kernel.h?

To be consistent with DIV_ROUND_UP, I'd rather name the new function
DIV_ROUND_CLOSEST. But other than that, yes I agree that making this an
inline function and moving it to kernel.h would be a good idea. Many
many hwmon drivers use this and people keep asking about this construct.

--
Jean Delvare
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/