Re: [RFC] SLUB - define OO_ macro instead of hardcoded numbers
From: Cyrill Gorcunov
Date: Wed Oct 22 2008 - 12:54:17 EST
[Cyrill Gorcunov - Wed, Oct 22, 2008 at 08:35:30PM +0400]
| [Christoph Lameter - Wed, Oct 22, 2008 at 09:28:14AM -0700]
| > On Wed, 22 Oct 2008, Cyrill Gorcunov wrote:
| >> Please check -- wouldn't it be better to use such a macro?
| > Looks good. But could you rename OO_MAX to something different? There is
| > already s->max which may cause confusion because s->max is the maximum
| > number of objects in a slab. OO_MAX is the maximum mask?
| I supposed it would mean maximum object number inside page (ie quantity) which
| is happen to be the same value as OO_MASK. Maybe OO_MAX_OBJ?
| - Cyrill -
Btw Christoph fix me if I'm wrong but this 65535 is directly related to
16 bit shift. If we change the first value without changing the second we
just break the SLUB I guess. I didn't read/understand SLUB code in details
so could be wrong.
- Cyrill -
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/