Re: [PATCH 0/3] ftrace: separate ftrace from ftrace

From: Ingo Molnar
Date: Mon Oct 20 2008 - 12:31:38 EST

* Steven Rostedt <rostedt@xxxxxxxxxxx> wrote:

> There has been a lot of confusion between ftrace the infrastructure
> and ftrace the function tracer within ftrace. Developers have added
> dependencies on HAVE_FTRACE when they did not need to. The HAVE_FTRACE
> was the architecture supported the function tracer.
> This patch series renames the ftrace function tracer to just that,
> FUNCTION_TRACER. And even renames the tracer shown to users from
> 'ftrace' to 'function'.
> Now, when referring to ftrace, it means the ftrace infrastructure, and
> when referring to the function trace, it is now called the function
> tracer.
> The second patch cause a lot of files to be touched. Mostly Makefiles
> and Kconfig files. As well as default configs.

applied the following bits to tip/tracing/ftrace:

3ce83ae: ftrace: rename the ftrace tracer to function
606576c: ftrace: rename FTRACE to FUNCTION_TRACER
c2db805: ftrace: fix depends
bd95b88: ftrace: release functions from hash
c513867: ftrace: do not enclose logic in WARN_ON

thanks Steve! I left out the defconfig bits - out of sync symbol names
there do not hurt, and those files are high-flux anyway and generally
updated by the arch maintainers regularly.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at