Re: [PATCH v2] ftrace: Add a C-state tracer to help poweroptimization

From: Ingo Molnar
Date: Sun Oct 05 2008 - 05:53:48 EST



* Steven Rostedt <rostedt@xxxxxxxxxxx> wrote:

>
> My comments are more towards Ingo than to Arjan.
>
> On Sat, 4 Oct 2008, Arjan van de Ven wrote:
> > +++ b/kernel/trace/Kconfig
> > @@ -134,6 +134,17 @@ config BOOT_TRACER
> > be enabled if this tracer is selected since only one tracer
> > should touch the tracing buffer at a time.
> >
> > +config CSTATE_TRACER
> > + bool "Trace C-state behavior"
> > + depends on HAVE_FTRACE
>
> Ingo, here's the confusion again between the FTRACE infrastructure and
> the ftrace "function tracer". the HAVE_FTRACE should really be
> HAVE_FUNCTION_TRACER. The infrastructure of a lot of the ftrace
> tracers do not depend on the function tracer.
>
> The CSTATE_TRACER also does not depend on HAVE_FTRACE. Think we should
> rename this? Otherwise more kernel developers will get confused by it.
> :-(

agreed, please send a rename patch to make it more consistent.

> > +static enum print_line_t cstate_print_line(struct trace_iterator *iter)
> > +{
> > + int ret;
> > + struct trace_entry *entry = iter->ent;
> > + struct trace_cstate *field = (struct trace_cstate *)entry;
>
> Ingo, isn't the trace_assign_type in your latest tree?

yeah, it is, and it should be used here instead of a direct cast.

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/