Re: Possible false positive in checkpatch

From: Andy Whitcroft
Date: Tue Aug 12 2008 - 13:18:19 EST


On Tue, Aug 12, 2008 at 05:29:02PM +0200, Krzysztof Halasa wrote:
> Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> writes:
>
> > ERROR: space prohibited after that '*' (ctx:BxW)
>
>
> > Certainly this is a rather uncommon code construction, but similar
> > ones might occur elsewhere. To my eyes,
> >
> > (* (type *) ptr)
> >
> > looks better than
> >
> > (*(type *) ptr)
> >
> > or
> >
> > (*(type *)ptr)
> >
> > or even
> >
> > (*(type*)ptr)
> >
> > but of course this is a matter of opinion. Is there any strong feeling
> > about this in the kernel community?
>
> I think checkpatch already has gone way too far with this (and not
> only this).
>
> "type *var" vs "type* var" - sure, the latter is worse and provokes
> "type* var1, var2", but anything else is IMHO only annoying and,
> actually, not important WRT readability at all.
>
> For example I prefer "type* func()" - as it's a function returning
> "a pointer to type" and not "a pointer to a function returning type"
> (which "type *func()" may suggest). Yes, func is not a pointer, so why
> write "*" next to it?

The recommendations it makes match the style of the whole, which new
contributions should follow. To a lot of people these nuances don't
matter to others they do. checkpatch aims to tell you what you will
likely be picked up on. Its recommending a standardised style that is
not necessarily what any one of us would use. But that is its role.
Feel free to ignore any of its recommendations, but expect to be pulled
up on a lot of them if you do; remembering the time of the reviewer
that is wasted in doing so.

-apw
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/