Re: Possible false positive in checkpatch

From: Krzysztof Halasa
Date: Tue Aug 12 2008 - 11:29:22 EST


Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> writes:

> ERROR: space prohibited after that '*' (ctx:BxW)


> Certainly this is a rather uncommon code construction, but similar
> ones might occur elsewhere. To my eyes,
>
> (* (type *) ptr)
>
> looks better than
>
> (*(type *) ptr)
>
> or
>
> (*(type *)ptr)
>
> or even
>
> (*(type*)ptr)
>
> but of course this is a matter of opinion. Is there any strong feeling
> about this in the kernel community?

I think checkpatch already has gone way too far with this (and not
only this).

"type *var" vs "type* var" - sure, the latter is worse and provokes
"type* var1, var2", but anything else is IMHO only annoying and,
actually, not important WRT readability at all.

For example I prefer "type* func()" - as it's a function returning
"a pointer to type" and not "a pointer to a function returning type"
(which "type *func()" may suggest). Yes, func is not a pointer, so why
write "*" next to it?
--
Krzysztof Halasa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/