Re: [PATCH 1/2] x86: rename PTE_MASK to PTE_PFN_MASK

From: Johannes Weiner
Date: Tue Jul 22 2008 - 09:04:18 EST

Jeremy Fitzhardinge <jeremy@xxxxxxxx> writes:

> Rusty, in his peevish way, complained that macros defining constants
> should have a name which somewhat accurately reflects the actual
> purpose of the constant.
> Aside from the fact that PTE_MASK gives no clue as to what's actually
> being masked, and is misleadingly similar to the functionally entirely
> different PMD_MASK, PUD_MASK and PGD_MASK, I don't really see what the
> problem is.

PTE_PFN_MASK is not symmetric to PAGE_MASK. How about PTE_PROT_MASK?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at