Re: [PATCH 1/2] x86: rename PTE_MASK to PTE_PFN_MASK

From: Ingo Molnar
Date: Tue Jul 22 2008 - 07:56:21 EST

* Rusty Russell <rusty@xxxxxxxxxxxxxxx> wrote:

> On Tuesday 22 July 2008 18:36:26 Ingo Molnar wrote:
> > * Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:
> > > Rusty, in his peevish way, complained that macros defining constants
> > > should have a name which somewhat accurately reflects the actual
> > > purpose of the constant.
> >
> > Applied to tip/x86/cleanups anyway. Rusty will find out himself how bad
> > this whole concept of clean and understandable code is, soon enough!
> I am disgusted with this inappropriate emphasis on clarity over
> obscurity. It should be pretty clear to everyone here that we can't
> have both!
> Fortunately, there is a way to partially rectify the situation. Ingo,
> please apply.

> +/* There's something suspicious about this line: see PTE_PFN_MASK comment. */
> #define __PHYSICAL_MASK ((phys_addr_t)(1ULL << __PHYSICAL_MASK_SHIFT) - 1)

> /* PTE_PFN_MASK extracts the PFN from a (pte|pmd|pud|pgd)val_t */
> +/* This line is quite subtle. See __PHYSICAL_MASK comment above. */
> #define PTE_PFN_MASK ((pteval_t)PHYSICAL_PAGE_MASK)

Now that you and Jeremy have thoroughly destroyed this file's obscurity
with your disgusting cleanups and clarifications, i fear it's beyond
repair. No matter how much i'd love to apply this infinitely recursive
piece of documentation (what a genius it takes to even think of it!) i
regret that i cannot. So sad.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at