Re: [PATCH] x86: let 32bit use apic_ops too

From: Yinghai Lu
Date: Sat Jul 12 2008 - 21:45:21 EST


On Sat, Jul 12, 2008 at 6:43 PM, Maciej W. Rozycki <macro@xxxxxxxxxxxxxx> wrote:
> On Fri, 11 Jul 2008, Yinghai Lu wrote:
>
>> -void apic_wait_icr_idle(void)
>> +void xapic_wait_icr_idle(void)
>> {
>> while (apic_read(APIC_ICR) & APIC_ICR_BUSY)
>> cpu_relax();
>> }
>>
>> -u32 safe_apic_wait_icr_idle(void)
>> +u32 safe_xapic_wait_icr_idle(void)
>
> Etc... Why are you changing names of these functions? Are they meant
> not to apply to older APIC implementations anymore?

because 64bit has that name.

YH
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/