Re: [PATCH 0 of 4] mm+paravirt+xen: add pte read-modify-writeabstraction

From: Linus Torvalds
Date: Fri May 23 2008 - 14:58:59 EST




On Fri, 23 May 2008, Jeremy Fitzhardinge wrote:
>
> This series adds the pte_rmw_start() and pte_rmw_commit() operations,
> which change this sequence to:
>
> ptent = pte_rmw_start(mm, addr, pte);
> ptent = pte_modify(ptent, newprot);
> /* ... */
> pte_rmw_commit(mm, addr, pte, ptent);

Can you please rename these.

It's not a general "read-modify-write" operation on the PTE, and this
*only* works for changing protection details. In particular, you cannot
use pte_rmw_start/commit to change the actual page. So it's very much
about just protection bits.

It should probably also be called ptep_xyz(), since it takes a pte
pointer, not a pte.

So maybe calling it "ptent = ptep_modify_prot_start(..)" ...
"ptep_modify_prot_commit(..)" or something.

Linus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/