Re: [34/37] Large blocksize support in ramfs

From: Christoph Lameter
Date: Wed Jun 20 2007 - 17:29:32 EST


On Wed, 20 Jun 2007, Andreas Dilger wrote:

> On Jun 20, 2007 11:29 -0700, clameter@xxxxxxx wrote:
> > If you apply this patch and then you can f.e. try this:
> >
> > mount -tramfs -o10 none /media
>
> > @@ -164,10 +165,15 @@ static int ramfs_fill_super(struct super
> > + if (options && *options)
> > + order = simple_strtoul(options, NULL, 10);
>
> This is probably a bad name for a mount option. What about "order=10"?
> Otherwise you prevent any other option from being used in the future.

I tried to make it as simple as possible. The patch is primarily useful as
a debugging aid since it eliminates the lower layers from the game. I
think ramfs should be left as is sine it is intended as a minimal
implementation that should stay simpl.

If we really want such an option for good then it may best be added to
shmem or ramdisk drivers?

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/