Re: [patch 03/26] Xen-paravirt_ops: use paravirt_nop to consistently mark no-op operations

From: Ingo Molnar
Date: Fri Mar 16 2007 - 05:45:14 EST



* Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:

> Add a _paravirt_nop function for use as a stub for no-op operations,
> and paravirt_nop #defined void * version to make using it easier
> (since all its uses are as a void *).
>
> This is useful to allow the patcher to automatically identify noop
> operations so it can simply nop out the callsite.

Acked-by: Ingo Molnar <mingo@xxxxxxx>

> +void _paravirt_nop(void);
> +#define paravirt_nop ((void *)_paravirt_nop)

but only as a cleanup of the current open-coded (void *) casts. My
problem with this is that it loses the types. Not that there is much to
check for, but still, this adds some assumptions about how function
calls look like.

Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/