Re: [PATCH 2.6.18 real-V5] drivers: add lcd display support

From: Andrew Morton
Date: Wed Sep 27 2006 - 18:42:33 EST


On Wed, 27 Sep 2006 20:58:24 +0000
"Miguel Ojeda" <maxextreme@xxxxxxxxx> wrote:

> On 9/26/06, Andrew Morton <akpm@xxxxxxxx> wrote:
> > It's also probably-incorrect on big-endian CPUs.
> > Perhaps you should not
> > use bitops at all for this driver, use open-coded |
> > and &/~ instead?
>
> Uhm, someone told me that they shouldn't be used because the kernel
> has generic functions for that.

You can't believe everything you read on the internet ;)

set_bit() and friends are a) atomic wrt other CPUs on SMP and b) only to be
performed on unsigned longs.

> I researched the kernel sources, and looking at bitops.h I found
> setbit(), so I tried to use it in the driver, althought I prefer
> standard |= and &=.

Those are the appropriate operations to use in this driver.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/