Re: [PATCH 2.6.18 real-V5] drivers: add lcd display support

From: Miguel Ojeda
Date: Wed Sep 27 2006 - 16:58:54 EST

On 9/26/06, Andrew Morton <akpm@xxxxxxxx> wrote:
It's also probably-incorrect on big-endian CPUs.
Perhaps you should not
use bitops at all for this driver, use open-coded |
and &/~ instead?

Uhm, someone told me that they shouldn't be used because the kernel
has generic functions for that.

I researched the kernel sources, and looking at bitops.h I found
setbit(), so I tried to use it in the driver, althought I prefer
standard |= and &=.

Are there more generic bitops kernel functions I may didn't find and I
should use in the future?

Anyway, it's just a question: I will turn back the driver to use |=
and &=, they look better to me too.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at