Re: sound/pci/hda/intel_hda: small cleanups

From: Pavel Machek
Date: Thu Aug 31 2006 - 09:36:57 EST


Hi!

> > @@ -271,8 +272,8 @@ struct azx_dev {
> > /* for sanity check of position buffer */
> > unsigned int period_intr;
> >
> > - unsigned int opened: 1;
> > - unsigned int running: 1;
> > + unsigned int opened :1;
> > + unsigned int running :1;
> > };
> >
> > /* CORB/RIRB */
> > @@ -330,8 +331,8 @@ struct azx {
> >
> > /* flags */
> > int position_fix;
> > - unsigned int initialized: 1;
> > - unsigned int single_cmd: 1;
> > + unsigned int initialized :1;
> > + unsigned int single_cmd :1;
> > };
>
> Any official standard reference for bit-field expressions?

Well, logically : belongs to the 1, and include/linux understands it
like that...

> > /* driver types */
> > @@ -642,14 +643,14 @@ static int azx_reset(struct azx *chip)
> > azx_writeb(chip, GCTL, azx_readb(chip, GCTL) | ICH6_GCTL_RESET);
> >
> > count = 50;
> > - while (! azx_readb(chip, GCTL) && --count)
> > + while (!azx_readb(chip, GCTL) && --count)
> > msleep(1);
>
> Hm, it looks rather like a personal preference.
> IMHO, it's harder to read without space...

Well, core parts (sched.c?) use it without the space, and I'd say (!
expression) is unusual in kernel, but no, could not find it codified.

> I'll fix the volatile things separately.

Thanks.
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/