Re: sound/pci/hda/intel_hda: small cleanups

From: Takashi Iwai
Date: Thu Aug 31 2006 - 09:03:14 EST


At Thu, 31 Aug 2006 14:37:06 +0200,
Pavel Machek wrote:
>
> @@ -271,8 +272,8 @@ struct azx_dev {
> /* for sanity check of position buffer */
> unsigned int period_intr;
>
> - unsigned int opened: 1;
> - unsigned int running: 1;
> + unsigned int opened :1;
> + unsigned int running :1;
> };
>
> /* CORB/RIRB */
> @@ -330,8 +331,8 @@ struct azx {
>
> /* flags */
> int position_fix;
> - unsigned int initialized: 1;
> - unsigned int single_cmd: 1;
> + unsigned int initialized :1;
> + unsigned int single_cmd :1;
> };

Any official standard reference for bit-field expressions?

>
> /* driver types */
> @@ -642,14 +643,14 @@ static int azx_reset(struct azx *chip)
> azx_writeb(chip, GCTL, azx_readb(chip, GCTL) | ICH6_GCTL_RESET);
>
> count = 50;
> - while (! azx_readb(chip, GCTL) && --count)
> + while (!azx_readb(chip, GCTL) && --count)
> msleep(1);

Hm, it looks rather like a personal preference.
IMHO, it's harder to read without space...


> @@ -999,8 +1000,7 @@ static struct snd_pcm_hardware azx_pcm_h
> .info = (SNDRV_PCM_INFO_MMAP | SNDRV_PCM_INFO_INTERLEAVED |
> SNDRV_PCM_INFO_BLOCK_TRANSFER |
> SNDRV_PCM_INFO_MMAP_VALID |
> - SNDRV_PCM_INFO_PAUSE /*|*/
> - /*SNDRV_PCM_INFO_RESUME*/),
> + SNDRV_PCM_INFO_PAUSE),

The commented out item is there intentionally to indicate that the
full-resume isn't implemented.


I'll fix the volatile things separately.


Thanks,

Takashi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/