Re: [PATCH 2/2] usbhid: HID device simple driver interface

From: Arnd Bergmann
Date: Wed Jul 26 2006 - 19:52:32 EST

On Wednesday 26 July 2006 18:10, Josef Sipek wrote:
> You should use (hid) instead of hid. Because of how the pre-processor works.

Or, even better, use an inline function instead of a macro whereever

One more thing, the description for patch 1 can probably be refined
a bit more and put into Documentation/somewhere as a new file.

Regarding the split of the patch, it's usually a bad idea to
put the header file into a separate patch from its users.
E.g. if someone during debugging tries to revert patch 2 but not
patch 1, he ends up with a broken build.

Arnd <><
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at