Re: [PATCH] xfs: kill kmem_zone init

From: Nathan Scott
Date: Mon Mar 20 2006 - 16:18:13 EST


On Mon, Mar 20, 2006 at 03:04:14PM +0200, Pekka J Enberg wrote:
> Hi!

Hi Pekka,

> This patch changes kmem_zone_init() callers to use kmem_cache_alloc() so
> we can kill the wrapper.

Sorry, but thats just silly. Did you even look at the code
around what you're changing (it has to do more than just wrap
up slab calls)? So, NACK on this patch - it leaves the code
very confused (half zoney, half slaby), and is just unhelpful
code churn at the end of the day.

For your zalloc patch, you will need to duplicate the logic
in kmem_zone_alloc into kmem_zone_zalloc in order to use that
new zalloc interface you're introducing - which should be fine.

cheers.

--
Nathan
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/