Re: [PATCH 1/3] mm: rename kmem_cache_s to kmem_cache

From: Andrew Morton
Date: Mon Oct 31 2005 - 03:15:32 EST


Pekka Enberg <penberg@xxxxxxxxxxxxxx> wrote:
>
> This patch renames struct kmem_cache_s to kmem_cache so we can start using it
> instead of kmem_cache_t typedef.

Well I stared at these diffs for a long time. They don't really add a lot
of value to the kernel and they do risk breaking other people's patches.
Generally they have a high hassle/value ratio.

I could merge them up and see how it goes, but given that there are many
more kmem_cache_t->struct kmem_cache conversions to go, and that I hit
seven rejects in mm/slab.c, I think I'll duck the patches, sorry.


> -void filp_ctor(void * objp, struct kmem_cache_s *cachep, unsigned long cflags)
> +void filp_ctor(void * objp, struct kmem_cache *cachep, unsigned long cflags)

See the inconsistent coding style there? This would have been a zero-cost
opportunity to fix that up. (Nuke the space after the asterisk).
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/