Re: [PATCH 2.6.13] x86_64: Rename KDB_VECTOR to NMI_VECTOR

From: Andi Kleen
Date: Fri Sep 09 2005 - 03:07:34 EST


On Thursday 08 September 2005 18:39, Tom Rini wrote:
> The existing hook from KDB in the IPI code is really just a hook for the
> NMI vector. We rename the vector thusly and then it's up to the
> debugger to handle things from do_default_nmi().

Jan Beulich pointed out some problems with this:

- First NMI vector is always 2 in the x86 architecture, so calling
another vector NMI_VECTOR is misleading.

- And when an NMI is forced in ICR the x86 architecture specifies
that the interrupt is delivered to vector 2.

Intel IA32 vol 3 8-23:

>>

100 (NMI) Delivers an NMI interrupt to the target processor
or processors. The vector information is ignored.
<<

So how did this ever work? I suspect you just got reentered
via the hooks in the NMI handler, but never through this vector.

I think I'll just remove this unless someone can explain how
it is supposed to work.

Thanks,
-Andi

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/