Re: [patch] ucb1x00: touchscreen cleanups

From: Russell King
Date: Sat Jul 30 2005 - 04:19:38 EST


On Tue, Jul 26, 2005 at 09:46:27AM +0200, Pavel Machek wrote:
> @@ -55,20 +54,6 @@ struct ucb1x00_ts {
>
> static int adcsync;
>
> -static inline void ucb1x00_ts_evt_add(struct ucb1x00_ts *ts, u16 pressure, u16 x, u16 y)
> -{
> - input_report_abs(&ts->idev, ABS_X, x);
> - input_report_abs(&ts->idev, ABS_Y, y);
> - input_report_abs(&ts->idev, ABS_PRESSURE, pressure);
> - input_sync(&ts->idev);
> -}
> -
> -static inline void ucb1x00_ts_event_release(struct ucb1x00_ts *ts)
> -{
> - input_report_abs(&ts->idev, ABS_PRESSURE, 0);
> - input_sync(&ts->idev);
> -}
> -

Only one query: What's the reason for moving these? I think keeping
them makes the code more readable.

--
Russell King
Linux kernel 2.6 ARM Linux - http://www.arm.linux.org.uk/
maintainer of: 2.6 Serial core
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/