Re: Alternative to TIF_FREEZE -> a notifier in the task_struct?

From: Christoph Lameter
Date: Thu Jul 28 2005 - 14:53:20 EST

On Thu, 28 Jul 2005, Pavel Machek wrote:

> > > I guess I'd prefer if you left "refrigerator()" and "try_to_freeze()"
> > > functions in; there are about 1000 drivers that know/use them, and
> > > some patches are probably in the queue....
> >
> > Yeah but then other uses also could benefit from that.
> Just don't rename try_to_freeze() to whatever... make it do whatever
> you need, but don't change the name so that we don't have to fix it at
> 1000 places...

Ok. Patchset will follow soon.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at