Re: Alternative to TIF_FREEZE -> a notifier in the task_struct?

From: Pavel Machek
Date: Thu Jul 28 2005 - 14:41:09 EST


> > I guess I'd prefer if you left "refrigerator()" and "try_to_freeze()"
> > functions in; there are about 1000 drivers that know/use them, and
> > some patches are probably in the queue....
> Yeah but then other uses also could benefit from that.

Just don't rename try_to_freeze() to whatever... make it do whatever
you need, but don't change the name so that we don't have to fix it at
1000 places...

Or introduce new name, but keep try_to_freeze in, just calling "new"
function, so all 1000 usews don't have to be changed at the same time.

teflon -- maybe it is a trademark, but it should not be.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at