Re: FW: PROBLEM: Devices behind PCI Express-to-PCI bridge not mapped

From: Peter Buckingham
Date: Tue Jun 21 2005 - 13:42:25 EST

Hi Brian,

Hodle, Brian wrote:
I am experiencing exactly the same problem. I am using an ASUS
K8N-DL MB with the x86_64 kernel. My PCIX devices are not allocated
correctly. I tried using the 'pci=routeirq' option to no avail. Disabling
ACPI in the BIOS does not help the situation either. X will not use my PCIX
for GLX since none of the extra txture memory has been allocated! Anyone
have any ideas?

well my system is using PCIe instead so it's a little different. It seems that the PCIe fixups are enough to get the BAR regions assigned correctly. prior to loading the nvidia driver the BARs are listed as disabled in lspci -vvx, but after loading the BARs are not disabled and I am able run X on both GPUs fine. I haven't tried running any OpenGL type tests yet on the system.

pci=routeirq is a red herring, this is about the interrupts and shouldn't affect the bar allocation.

it might be useful for you to post a dmesg with PCI_DEBUG enabled and specify which kernel version you are using. My system only worked with the most recent 2.6.12 (but i think that's due to some of the pci express changes and some of the bridge handling since our system is a little unique...)

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at