FW: PROBLEM: Devices behind PCI Express-to-PCI bridge not mapped

From: Hodle, Brian
Date: Tue Jun 21 2005 - 09:12:11 EST

-----Original Message-----
From: Hodle, Brian
Sent: Tuesday, June 21, 2005 8:53 AM
To: 'Peter Buckingham'
Subject: RE: PROBLEM: Devices behind PCI Express-to-PCI bridge not

I am experiencing exactly the same problem. I am using an ASUS
K8N-DL MB with the x86_64 kernel. My PCIX devices are not allocated
correctly. I tried using the 'pci=routeirq' option to no avail. Disabling
ACPI in the BIOS does not help the situation either. X will not use my PCIX
for GLX since none of the extra txture memory has been allocated! Anyone
have any ideas?



-----Original Message-----
From: Peter Buckingham [mailto:peter@xxxxxxxxxxxx]
Sent: Monday, June 20, 2005 4:31 PM
To: Ivan Kokshaysky
Cc: sean.bruno@xxxxxxxxxxxx; koch@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx;
torvalds@xxxxxxxx; benh@xxxxxxxxxxxxxxxxxxx;
linux-pci@xxxxxxxxxxxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx;
Subject: Re: PROBLEM: Devices behind PCI Express-to-PCI bridge not

Hi Ivan,

I've just tried a recent pull from Linus post 2.6.12. It seems that the
bar sizes are now (mostly) correct. However, there are still issues with
the resources failing to be allocated and the bars being disabled. I've
attached the latest dmesg and lspci -vvx to see whether there's any
enlightenment out there...


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/