USB problems: SanDisk SDDR-75 / Apacer AP-MSCRU10 card readers

From: Vanja Hrustic
Date: Mon Apr 19 2004 - 07:51:55 EST

I have purchased SanDisk SDDR-75 card reader, since it was reported on
quite few places to work (even with RH 7.3) ok on Linux.

However, I am experiencing problems with it, as well as with another
reader I have (Apacer AP-MSCRU10).

Kernel is 2.4.26 (tried 2.4.25 as well), on RedHat 9. System is XP2500, on
NForce2 motherboard.

Basically, when I plug card reader into USB port, it gets initialized but
strange things happen. Sometimes, machine hangs completely, sometimes it
hangs when I issue fdisk or mount commands, and in cases when it doesn't
hang, I can't see CF disks in the drive. In rare cases when I do see the
CF and can mount it, any bigger (more than 2-3MB) copy operation to CF
will hang, and I have to disconnect the reader.

SanDisk SDDR-75 has 2 slots, Apacer AP-MSCRU10 has 3 slots.

But if I connect the digital camera (Nikon CoolPix 4300, has one CF slot),
everything works just fine, and I have no trouble with it.

I have also tried changing /etc/modules.conf and adding options scsi_mod
max_scsi_luns=X (where X was anywhere between 0 and 6, depending on what
was connected and if SCSI emulation was enabled for CD-ROMs). I have seen
this suggestion for some card readers, but it didn't help in my case.

I have attached output of 'grep "=[y|m]" .config' file to this mail.

Outputs (from /var/log/messages) for SanDisk, Apacer and Nikon are placed

SanDisk SDDR-75

Apacer AP-MSCRU10

Nikon CoolPix 4300

There are no errors when Nikon is connected, but SanDisk/Apacer give
errors like:

usb-storage: Fixing INQUIRY data to show SCSI rev 2 - was 0

lspci -vvv output:

I can provide much more details (for example, when I try to access the
device, if computer doesn't hang, much more errors come out), and I would
appreciate any help (or pointers as what else to try, where to look) with
this. I don't want to send too much output to the list, so I don't mind
continuing this off the list - I would post the summary later, if I manage
to fix this.



Attachment: kernel.config
Description: Binary data