Re: [Swsusp-devel] Re: RTC causes hard lockups in 2.5.70-mm8

From: Florian-Daniel Otel (
Date: Thu Jun 19 2003 - 03:41:13 EST

I can confirm the RTC problems on a Fujitsu LifeBook P2120 (Crusoe
TM5800, ALi, ACPI). In my case I was even more fortunate (??) since
using RTC (either compiled-in in the kernel and/or as a module), any
call to "hwclock" locks the machine rock solid (not even SysRQ
works). So for me the RTC issue is not at all swsusp related.

Back to swsusp: I'm more than happy to annonce that I just discovered
that -pre11 works !! Actually, after reading a bit more closely this
list (*gasp*) and trying the suspend the machine AFTER modules were
unloaded (WLAN, USBs), networking stopped and all non-critical daemons
terminated (basically switching to run-level 1, terminating daemons
and unloading modules), the suspend worked !! And resuming too :)) !!

As such, after a horrible hack of the old script (from
swsusp-beta17) and using "echo -n 4 > /proc/acpi/sleep" the
suspension+resuming process worked (at least once...).

On less extatic but more useful note: It seems that if I start the
suspending process by hand (i.e. swsusp utility) while PCMCIA and USBs
are stopped but __not__ networking, the resume process freezes. I can
use SysRq+T at this point, but since this is a "legacy free" laptop, I
have no idea how to hook on a serial console there and come w/ a
useful bug report. If anyone has an idea how to do that, I'll be more
than happy to help w/ more testing.



To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon Jun 23 2003 - 22:00:28 EST