Re: Linux 2.5.60

From: Linus Torvalds (
Date: Tue Feb 11 2003 - 02:38:01 EST

On Tue, 11 Feb 2003, Oleg Drokin wrote:
> One of yours hand merged UML updates/fixes in, and another one broke it badly by introducing
> sigprocmask(). Now there is a conflict between in-kernel sigprocmask() and
> glibc's sigprocmask() (that UML uses to manage signal delivery to right thread).
> Can we please change the name of in-kernel's sigprocmask() to avoid name clash? ;)

No. I'm not goinmg to start caring about user-land naming in-kernel, that
way is a slippery slope. This is firmly a UML problem.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Sat Feb 15 2003 - 22:00:31 EST