Re: Linux 2.5.60

From: Oleg Drokin (
Date: Tue Feb 11 2003 - 02:08:47 EST


On Mon, Feb 10, 2003 at 11:08:28AM -0800, Linus Torvalds wrote:

> Networking, USB, SCSI, ALSA, ACPI, and various architecture updates (UML,
> Sparc, ia64, ppc64 and ARM).

One of yours hand merged UML updates/fixes in, and another one broke it badly by introducing
sigprocmask(). Now there is a conflict between in-kernel sigprocmask() and
glibc's sigprocmask() (that UML uses to manage signal delivery to right thread).
Can we please change the name of in-kernel's sigprocmask() to avoid name clash? ;)
Jeff Dike is also seem to support idea of renaming the offending function.

Thank you.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Sat Feb 15 2003 - 22:00:31 EST