Re: [PATCH] a more efficient BUG() macro

From: Andi Kleen (
Date: Sun Feb 18 2001 - 09:27:01 EST

Keith Owens <> writes:
> Would people prefer the C/ASM filename in BUG() messages instead of the
> include header? If so I will add it to my todo list for the makefile
> rewrite. Of course you can still use __FILE__ and __LINE_ if you
> really want to report the error against the include file.

I think include file name makes more sense, otherwise you'll have a hard time
to find the actual BUG check. If someone wants more they can decode the oops.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Fri Feb 23 2001 - 21:00:17 EST