Olaf Titz <olaf@bigred.inka.de> wrote:
> You mean, define that to a suitable array? Like
> __u32 x;
> addrstr_ipv4_t adr;
> addrstr_ipv4_ntoa(&adr, x);
> printk("%s", adr);
The function should actually return the formatted string:
__u32 x;
addrstr_ipv4_t adr;
printk ("%s", ipv4_ntoa(adr, x));
Saves a few lines and is more readable.
Regards
Joerg
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/
This archive was generated by hypermail 2b29 : Sun Apr 23 2000 - 21:00:12 EST