core files (was Re: 2.1.131: some quality thoughts)

Albert D. Cahalan (acahalan@cs.uml.edu)
Sat, 19 Dec 1998 00:29:32 -0500 (EST)


Olaf Titz writes:
> [someone]

>> is a terrible name for anything but a core-file.
>> In fact, core isn't even a good name for a core file

Sure, we need a config option:

*
* Memory type
*
Memory type (tube, mercury, core, sram, dram, sdram) [sdram]
defined CONFIG_SDRAM

>> (I think the core-file name should
>> include the executable file name and the PID). Something like
>
> Once upon a time Linux did dump core into "core.NAME" with the
> appropriate executable NAME, but that was changed because the
> assumption that a core file is named "core" is about as deeply
> entrenched in Un*x minds as the assumption that SIGKILL==9.
>
> IOW, too many complaints that "it breaks other stuff".

Yes, nobody knows what core.tar is. Prefixes are just bad.

Considering the millions of real users out there, "program.bug" would
be a much better name. The discovery of a file named "core" is not
likely to generate a bug report.

If anyone cares enough, support this:

echo "core.%c" > /proc/sys/kernel/corename

For admin compatibility with the new /bin/ps, you should use these codes:

CODE NORMAL HEADER
%C pcpu %CPU
%G group GROUP
%P ppid PPID
%U user USER
%a args COMMAND
%c comm COMMAND
%g rgroup RGROUP
%n nice NI
%p pid PID
%r pgid PGID
%t etime ELAPSED
%u ruser RUSER
%x time TIME
%y tty TTY
%z vsz VSZ

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/