oops in 2.0.32 w/AHA2940

Mitch Adair (mitch@acan.net)
Mon, 15 Dec 1997 13:23:39 -0600 (CST)

Got an oops and total lock-up running 2.0.32 on a server w/ an AHA-2940.
2.0.32 was patched with Doug Ledford's aic7xxx-abort-Nov05-32 patch.
Unfortunately, all that made it to syslog was this:

Dec 12 16:20:38 lyon kernel: wait_queue is bad (eip = 00128d47)
Dec 12 16:20:38 lyon kernel: q = 00c2554c
Dec 12 16:20:38 lyon kernel: *q = 00c25448

It happened while I was away from it (of course), but apparently stayed
up till the morning of the 13th. It was dead as a rock by the time somebody
got into look at it though. Just on the off chance it'd be useful I
grepped for the eip above in the System.map:

lyon:~$ grep 00128 /System.map
001280b0 T set_writetime
00128100 T refile_buffer
00128480 T __brelse
001284d0 T __bforget
00128560 T bread
001285f0 T breada
00128780 t get_more_buffer_heads
00128820 t get_unused_buffer_head
00128880 t create_buffers
00128920 T brw_page
00128cd0 T mark_buffer_uptodate
00128d30 T unlock_buffer
00128e90 T generic_readpage
00128f10 t grow_buffers

Is there *any* way to get any more useful info? Oddly, the box had been
having problems w/2.0.32 from the begining - it stopped doing dns
correctly for sendmail - would return SIGILL when you tried to mail stuff,
but other dns worked fine, real weird. I left it up to see what would
happen & boom... I've gone back to 2.0.30 which seems to work fine (odd
considering the probs. others seem to have had with .30, but what can
you do?)

Anybody needs any more info, etc. just let me know.