Re: [linux-kernel] ext2fs problems with >64M ram

Robert L Harris (
Mon, 15 Dec 1997 11:14:45 -0700 (MST)

> Hi, I just replaced the 64M of memory in my dual PPro 200 with
> 128M (2 64M edo chips) but I cannot get the computer to run with
> the extra ram. If pass the argument mem=64M everything seems to
> run fine. If I dont pass any arguments at boot, I get an error
> right after the partition check:
> EXT2-fs error (device 08:02): ext2_check_descriptors: Inode bitmaps for
> group 0 not in group (block 32772)!
> EXT2-fs: group descriptors corrupted !
> kernel panic: VFS: Unable to mount root fs on 08:02
> If I pass arguments like mem=68M or mem=120M I get various errors, all
> related to ext2-fs, usually something like corrupt group or some other
> kind of error. One time it got almost all the way through the boot
> process but then had trouble finding files in the /bin dir after it
> booted.
> Is this a problem with the kernel or the ram? I thought it might be
> the kernel because of how stable the system is when I get it
> to boot with mem=64M. Is there any way to test the ram without having
> to mail it back to the supplier? Btw, I also tried changing the order
> of the chips in the simm slots (maybe 1 was bad?) but no difference in
> behavior.
> While booted with mem=64M I ran some programs that very intensively
> use up all the system memory and ran into no problems.
> The system:
> dual PPro 200 256k cache
> asus p/i-p65up5 motherboard
> adaptec 2940uw scsi
> 2 4gig ide, 1 2 gig scsi hard drives
> redhat-5.0
> linux-2.0.31-SMP

I got about the same thing although I blamed it on MicroSoft. I had
just re-installed 95 and had to redo my "lilo". When I booted I got
the same thing a few times. I rebuilt the lilo using the Redhat
boot/root disks and I'm ok now. One note is I have to power everything
off and wait a minute if it happens again and then I'm ok.

Dual Pent166
Tyan Tomcat MB
Adaptec 3940UW controller
3 2Gig Baracudas, 5 Quantum AtlasII drives


Robert L. Harris | NT is secure....
System Engineer For Hire. \_ as long as you don't remove the shrink wrap.

These are MY OPINIONS ALONE. I speak for no-one else.
perl -e 'print $i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10);'