[linux-kernel] ext2fs problems with >64M ram

C.J. Beyer (cj@styx.phy.Vanderbilt.Edu)
Mon, 15 Dec 1997 11:09:39 -0600 (CST)

Hi, I just replaced the 64M of memory in my dual PPro 200 with
128M (2 64M edo chips) but I cannot get the computer to run with
the extra ram. If pass the argument mem=64M everything seems to
run fine. If I dont pass any arguments at boot, I get an error
right after the partition check:

EXT2-fs error (device 08:02): ext2_check_descriptors: Inode bitmaps for
group 0 not in group (block 32772)!
EXT2-fs: group descriptors corrupted !
kernel panic: VFS: Unable to mount root fs on 08:02

If I pass arguments like mem=68M or mem=120M I get various errors, all
related to ext2-fs, usually something like corrupt group or some other
kind of error. One time it got almost all the way through the boot
process but then had trouble finding files in the /bin dir after it

Is this a problem with the kernel or the ram? I thought it might be
the kernel because of how stable the system is when I get it
to boot with mem=64M. Is there any way to test the ram without having
to mail it back to the supplier? Btw, I also tried changing the order
of the chips in the simm slots (maybe 1 was bad?) but no difference in

While booted with mem=64M I ran some programs that very intensively
use up all the system memory and ran into no problems.

The system:
dual PPro 200 256k cache
asus p/i-p65up5 motherboard
adaptec 2940uw scsi
2 4gig ide, 1 2 gig scsi hard drives

C.J. Beyer