compiling/using 2.1.72 kernel on RH4.2
Sun, 14 Dec 97 16:53:12 -0700

Sorry if this "spam" across multiple mailing lists annoys anyone, but I
really need some help. I've spent a lot of time reading documentation and
trying different things, so please keep that in mind. First is my original
message, followed by an update. Thanks for reading this far...

I've just installed RedHat 5.0, and I'm trying to use the 2.1.72 kernel,
since I want the increased functionality (joystick and SIS busmastering
EIDE). I downloaded the sources, compiled, and connected it to LILO. It
dies with the following error message:

"Kernel panic: No init found. Try passing init= option to kernel."

At which point it hangs, forcing a hard reboot. I have tried: setting
initrd to point to the 2.0.31 initrd image; using the noinitrd parameter
in lilo.conf; initrd=/bin/sh, no mention of initrd in lilo.conf at all;
and make zdisk for a floppy boot kernel. None of this helped. Obiviously I
am missing something here, could someone please clue me in?

I have applied no patches to the 2.1.72 source. I have applied the RH5.0
updates, and I am using a Cyrix CPU. I am currently still stuck with the
2.0.31 kernel, the install also of which failed, trying to compile it as
above (I haven't followed the "Kernel Upgrade Errata" procedure for that

BTW, with RH4.2, I sucessfully recompiled my kernel (with some patches!)
with no problems.

The next day...
OK, I've gone back to a complete reinstall of RH4.2 (5.0 seems to have
problems with my hardware, especially the Cyrix CPU). I read thru the
Documentation for the 2.1.72 kernel, and made sure all my software was up
to date to meet the minimum requirements for 2.1.72. I compiled a
completely monolithic kernel (to eliminate any possible module problems)
after failing with a modular kernel (I did suceed in getting past the
"panic" message with the 2.1.72 modular kernel after building/installing
the modules and running "mkinitrd /boot/initrd-2.1.72 2.1.72", but I then
got an endless stream of I/O errors!). To eliminate any possible problems
relating to my Adaptec SCSI card, I did not compile in support for it
(think that was the source of the I/O errors the one time I made some
progress!). I tried commenting out items relating to "depmod" in
rc.sysinit, as recommended by the RH4.2 kernel documentation. No
difference. Tried specifying "<kernel-name> init=\bin\sh" and later
"init=\sbin\init" with no sucess. Tried specifying "noinitrd" as a boot
parameter, and that didn't avoid the panic either. I also tried using the
initrd images from RH4.0 and 4.2, with no change in the panic message on

>From my understanding of the documentation, I should be able to boot a
monolithic kernel just fine without worrying about/using modules or
initrd. Please correct me if I am wrong in this.

I have successfully recomplied the RH4.2 2.0.30 kernel on my machine
today, and it comes up ok, but with a lot of errors relating to modules
that are no longer being loaded? (undefined symbols)

I do understand how to get LILO to see the new kernel, so I'm sure that is
not the problem (I can see the new features of 2.1.72 during the boot
process before the panic occurs).

My hardware:
Cyrix 6x86 PR200+, Mtech Mustang R534 w/ 512 cache, 64MB ram, Matrox
Millenium 2MB, Phillips CDD2600 6x2 SCSI CD-R, ATAPI 24X CDROM, SCSI ZIP,
Adaptec AHA-2490U rev B w/ BIOS rev 1.25.


What I need to know is, how to fix whatever I've done wrong so I can get
past that panic message with the 2.1.72 kernel. Thanks for any

Brian Hall     N4MIH     Certified Electronics Technician