2.1.72:(2.1.xx) OOPS on ifconfig of PCMCIA e-net card (8390)

Steve Dunham (dunham@cps.msu.edu)
12 Dec 1997 16:16:39 -0500

My Linksys PCMCIA ethernet card (8390) causes an Oops (and a crash)
when I ifconfig it.

I've been having this problem with all of the kernels I have tried in
the 2.1.x series (i.e most of 2.1.6x, 2.1.7x). I am using

Has anyone else seen this problem, or has anyone successfully used a
8390 based PCMCIA ethernet card with a recent kernel? Any ideas?

Below is the Oops from the 2.1.72 kernel (thanks to the serial console
support). Since ksymoops has problems with glibc, I ran it on a Sparc
(and, hence, have no disassembly). I've added comments about the
unresolved addresses (prefixed with "***").

lock from interrupt context at c01100e1
*** (this is <do_page_fault+21/3E0>)
Unable to handle kernel NULL pointer dereference at virtual address 0000012c
current->tss.cr3 = 00101000, %cr3 = 00101000
*pde = 00000000
Oops: 0000
CPU: 0
EIP: 0010:[<c18144c2>]
EFLAGS: 00010246
eax: 00000110 ebx: c066c6e0 ecx: c18153f3 edx: 00e80007
esi: 656e6370 edi: 00e80000 ebp: c0107f70 esp: c0107f44
ds: 0018 es: 0018 ss: 0018
Process swapper (pid: 0, process nr: 0, stackpage=c0107000)
Stack: 656e6370 00000000 00000020 c066c6e0 00000000 00000000 656e6370 00000001
c010efa2 00000110 00000000 c0107f94 c010b943 00000003 c1818b0c c0107f9c
00000100 c0107fdc 00000000 00000003 00001ff0 c010a000 00000100 00000000
Call Trace: [<c010efa2>] [<c0107f94>] [<c010b943>] [<c1818b0c>] [<c0107f9c>] [<c0107fdc>] [<c010a000>]
[<c0106000>] [<c0107fdc>] [<c0108269>] [<c0106000>] [<c01001d6>]

>>EIP: c18144c2 cannot be resolved

*** The closest thing is ksyms is:
*** c1814440 ei_interrupt_Rb93d8fa5 [8390]
*** It looks like:
*** <ei_interrupt+82/260> in the 8320.o module

Trace: c010efa2 <timer_interrupt+1e/94>
Trace: c0107f94 <this_must_match_init_task+1f94/2000>
Trace: c010b943 <do_IRQ+b3/15c>
Trace: c1818b0c

*** The closest thing is ksyms is
*** c1815694 ei_debug_R5a6a104c [8390]
*** Which is a data reference. It seems to be past everything in 8390.o

Trace: c0107f9c <this_must_match_init_task+1f9c/2000>
Trace: c0107fdc <this_must_match_init_task+1fdc/2000>
Trace: c010a000 <ret_from_intr>
Trace: c0107fdc <this_must_match_init_task+1fdc/2000>
Trace: c0107fdc <this_must_match_init_task+1fdc/2000>
Trace: c0108269 <cpu_idle+3d/11c>
Trace: c0107fdc <this_must_match_init_task+1fdc/2000>
Trace: c01001d6 <L6>
Code: f6 40 1c 08 74 05 b9 b2 53 81 c1 51 e8 49 0a 90 fe e9 b7 01

*** I didn't decode this because I was running ksymoops on a sparc
*** (glibc problems)

Aiee, killing interrupt handler
Kernel panic: Attempted to kill the idle task!
In swapper task - not syncing