Re: [PATCH v2 15/27] rcu: Rename rcu_dynticks_eqs_online() into rcu_watching_eqs_online()

From: Frederic Weisbecker
Date: Mon May 06 2024 - 18:18:31 EST


Le Tue, Apr 30, 2024 at 11:17:19AM +0200, Valentin Schneider a écrit :
> The context_tracking.state RCU_DYNTICKS subvariable has been renamed to
> RCU_WATCHING, reflect that change in the related helpers.
>
> Signed-off-by: Valentin Schneider <vschneid@xxxxxxxxxx>
> ---
> kernel/rcu/tree.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/rcu/tree.c b/kernel/rcu/tree.c
> index bb0d9dd8b6d3a..fe2beb7d2e82d 100644
> --- a/kernel/rcu/tree.c
> +++ b/kernel/rcu/tree.c
> @@ -280,7 +280,7 @@ void rcu_softirq_qs(void)
> }
>
> /*
> - * Reset the current CPU's ->dynticks counter to indicate that the
> + * Reset the current CPU's RCU_WATCHING counter to indicate that the
> * newly onlined CPU is no longer in an extended quiescent state.
> * This will either leave the counter unchanged, or increment it
> * to the next non-quiescent value.
> @@ -289,7 +289,7 @@ void rcu_softirq_qs(void)
> * of the ->dynticks counter are manipulated only by the corresponding CPU,
> * or when the corresponding CPU is offline.
> */
> -static void rcu_dynticks_eqs_online(void)
> +static void rcu_watching_eqs_online(void)

Or simply rcu_watching_online?

Thanks.

> {
> if (ct_rcu_watching() & CT_RCU_WATCHING)
> return;
> @@ -5051,7 +5051,7 @@ void rcutree_report_cpu_starting(unsigned int cpu)
> rnp = rdp->mynode;
> mask = rdp->grpmask;
> arch_spin_lock(&rcu_state.ofl_lock);
> - rcu_dynticks_eqs_online();
> + rcu_watching_eqs_online();
> raw_spin_lock(&rcu_state.barrier_lock);
> raw_spin_lock_rcu_node(rnp);
> WRITE_ONCE(rnp->qsmaskinitnext, rnp->qsmaskinitnext | mask);
> --
> 2.43.0
>