Re: [PATCH] livepatch.h: Add comment to klp transition state

From: Josh Poimboeuf
Date: Sun May 05 2024 - 17:00:36 EST


On Mon, Apr 29, 2024 at 03:26:28PM +0800, zhangwarden@xxxxxxxxx wrote:
> From: Wardenjohn <zhangwarden@xxxxxxxxx>
>
> livepatch.h use KLP_UNDEFINED\KLP_UNPATCHED\KLP_PATCHED for klp transition state.
> When livepatch is ready but idle, using KLP_UNDEFINED seems very confusing.
> In order not to introduce potential risks to kernel, just update comment
> to these state.
> ---
> include/linux/livepatch.h | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/include/linux/livepatch.h b/include/linux/livepatch.h
> index 9b9b38e89563..b6a214f2f8e3 100644
> --- a/include/linux/livepatch.h
> +++ b/include/linux/livepatch.h
> @@ -18,9 +18,9 @@
> #if IS_ENABLED(CONFIG_LIVEPATCH)
>
> /* task patch states */
> -#define KLP_UNDEFINED -1
> -#define KLP_UNPATCHED 0
> -#define KLP_PATCHED 1
> +#define KLP_UNDEFINED -1 /* idle, no transition in progress */
> +#define KLP_UNPATCHED 0 /* transitioning to unpatched state */
> +#define KLP_PATCHED 1 /* transitioning to patched state */

Instead of the comments, how about we just rename them to

KLP_TRANSITION_IDLE
KLP_TRANSITION_UNPATCHED
KLP_TRANSITION_PATCHED

which shouldn't break userspace AFAIK.

--
Josh