Re: [PATCH 12/21] pinctrl: k210: Use scope based of_node_put() cleanups

From: Damien Le Moal
Date: Thu May 02 2024 - 05:45:29 EST


On 5/1/24 21:56, Peng Fan (OSS) wrote:
> From: Peng Fan <peng.fan@xxxxxxx>
>
> Use scope based of_node_put() cleanup to simplify code.
>
> Signed-off-by: Peng Fan <peng.fan@xxxxxxx>
> ---
> drivers/pinctrl/pinctrl-k210.c | 7 ++-----
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/pinctrl/pinctrl-k210.c b/drivers/pinctrl/pinctrl-k210.c
> index b6d1ed9ec9a3..2753e14c3e38 100644
> --- a/drivers/pinctrl/pinctrl-k210.c
> +++ b/drivers/pinctrl/pinctrl-k210.c
> @@ -849,7 +849,6 @@ static int k210_pinctrl_dt_node_to_map(struct pinctrl_dev *pctldev,
> unsigned int *num_maps)
> {
> unsigned int reserved_maps;
> - struct device_node *np;
> int ret;
>
> reserved_maps = 0;
> @@ -861,13 +860,11 @@ static int k210_pinctrl_dt_node_to_map(struct pinctrl_dev *pctldev,
> if (ret < 0)
> goto err;
>
> - for_each_available_child_of_node(np_config, np) {
> + for_each_available_child_of_node_scoped(np_config, np) {
> ret = k210_pinctrl_dt_subnode_to_map(pctldev, np, map,
> &reserved_maps, num_maps);
> - if (ret < 0) {
> - of_node_put(np);

Personally, I am really not a fan of things that hide code like that scoped
thing... If I want a language that hides code, I would be doing C++ :)
That said, I am not opposed to this so I will let Linus (Walleij) decide.

Also, I think that "for_each_available_child_of_node" is a bad name... It really
should be something like for_each_available_child_of_node_get() to make it clear
that a of_node_put() is needed.

> + if (ret < 0)
> goto err;
> - }
> }
> return 0;
>
>

--
Damien Le Moal
Western Digital Research