[PATCH] phy: qualcomm: Use dev_err_probe()

From: ye.xingchen
Date: Thu Mar 23 2023 - 03:47:41 EST


From: Ye Xingchen <ye.xingchen@xxxxxxxxxx>

Replace the open-code with dev_err_probe() to simplify the code.

Signed-off-by: Ye Xingchen <ye.xingchen@xxxxxxxxxx>
---
drivers/phy/qualcomm/phy-qcom-ipq4019-usb.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/drivers/phy/qualcomm/phy-qcom-ipq4019-usb.c b/drivers/phy/qualcomm/phy-qcom-ipq4019-usb.c
index d3e7d5e1d1b6..190f12247235 100644
--- a/drivers/phy/qualcomm/phy-qcom-ipq4019-usb.c
+++ b/drivers/phy/qualcomm/phy-qcom-ipq4019-usb.c
@@ -110,11 +110,8 @@ static int ipq4019_usb_phy_probe(struct platform_device *pdev)
}

phy->por_rst = devm_reset_control_get(phy->dev, "por_rst");
- if (IS_ERR(phy->por_rst)) {
- if (PTR_ERR(phy->por_rst) != -EPROBE_DEFER)
- dev_err(dev, "POR reset is missing\n");
- return PTR_ERR(phy->por_rst);
- }
+ if (IS_ERR(phy->por_rst))
+ return dev_err_probe(dev, PTR_ERR(phy->por_rst), "POR reset is missing\n");

phy->srif_rst = devm_reset_control_get_optional(phy->dev, "srif_rst");
if (IS_ERR(phy->srif_rst))
--
2.25.1