Re: [PATCH v2 05/14] mm/page_alloc: rename page_alloc_init() to page_alloc_init_cpuhp()

From: Vlastimil Babka
Date: Wed Mar 22 2023 - 10:52:23 EST


On 3/21/23 18:05, Mike Rapoport wrote:
> From: "Mike Rapoport (IBM)" <rppt@xxxxxxxxxx>
>
> The page_alloc_init() name is really misleading because all this
> function does is sets up CPU hotplug callbacks for the page allocator.
>
> Rename it to page_alloc_init_cpuhp() so that name will reflect what the
> function does.
>
> Signed-off-by: Mike Rapoport (IBM) <rppt@xxxxxxxxxx>
> Reviewed-by: David Hildenbrand <david@xxxxxxxxxx>

Reviewed-by: Vlastimil Babka <vbabka@xxxxxxx>

> ---
> include/linux/gfp.h | 2 +-
> init/main.c | 2 +-
> mm/page_alloc.c | 2 +-
> 3 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/include/linux/gfp.h b/include/linux/gfp.h
> index 7c554e4bd49f..ed8cb537c6a7 100644
> --- a/include/linux/gfp.h
> +++ b/include/linux/gfp.h
> @@ -319,7 +319,7 @@ extern void page_frag_free(void *addr);
> #define __free_page(page) __free_pages((page), 0)
> #define free_page(addr) free_pages((addr), 0)
>
> -void page_alloc_init(void);
> +void page_alloc_init_cpuhp(void);
> void drain_zone_pages(struct zone *zone, struct per_cpu_pages *pcp);
> void drain_all_pages(struct zone *zone);
> void drain_local_pages(struct zone *zone);
> diff --git a/init/main.c b/init/main.c
> index 4425d1783d5c..b2499bee7a3c 100644
> --- a/init/main.c
> +++ b/init/main.c
> @@ -969,7 +969,7 @@ asmlinkage __visible void __init __no_sanitize_address start_kernel(void)
> boot_cpu_hotplug_init();
>
> build_all_zonelists(NULL);
> - page_alloc_init();
> + page_alloc_init_cpuhp();
>
> pr_notice("Kernel command line: %s\n", saved_command_line);
> /* parameters may set static keys */
> diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> index ff6a2fff2880..d1276bfe7a30 100644
> --- a/mm/page_alloc.c
> +++ b/mm/page_alloc.c
> @@ -6383,7 +6383,7 @@ static int page_alloc_cpu_online(unsigned int cpu)
> return 0;
> }
>
> -void __init page_alloc_init(void)
> +void __init page_alloc_init_cpuhp(void)
> {
> int ret;
>