Re: [PATCH v8 06/11] remoteproc: mediatek: Probe multi-core SCP

From: Mathieu Poirier
Date: Thu Mar 16 2023 - 17:07:46 EST


On Fri, Mar 03, 2023 at 04:33:50PM +0800, Tinghan Shen wrote:
> The difference of single-core SCP and multi-core SCP device tree is
> the presence of child device nodes described SCP cores. The SCP
> driver populates the platform device and checks the child nodes
> to identify whether it's a single-core SCP or a multi-core SCP.
>
> The resource structure of the multi-core SCP is a list of remoteproc
> instances which is different to the single-core SCP. The corresponding
> resource releasing action is based on the type of SCP.
>
> Signed-off-by: Tinghan Shen <tinghan.shen@xxxxxxxxxxxx>
> ---
> drivers/remoteproc/mtk_common.h | 4 +
> drivers/remoteproc/mtk_scp.c | 177 +++++++++++++++++++++++++++++---
> 2 files changed, 166 insertions(+), 15 deletions(-)
>
> diff --git a/drivers/remoteproc/mtk_common.h b/drivers/remoteproc/mtk_common.h
> index c0905aec3b4b..c088149e3dcc 100644
> --- a/drivers/remoteproc/mtk_common.h
> +++ b/drivers/remoteproc/mtk_common.h
> @@ -128,6 +128,10 @@ struct mtk_scp {
> size_t dram_size;
>
> struct rproc_subdev *rpmsg_subdev;
> +
> + struct list_head elem;
> + struct list_head cluster_cores;
> + struct list_head *cluster;
> };
>
> /**
> diff --git a/drivers/remoteproc/mtk_scp.c b/drivers/remoteproc/mtk_scp.c
> index bdb5d87eeaa3..84103a70f426 100644
> --- a/drivers/remoteproc/mtk_scp.c
> +++ b/drivers/remoteproc/mtk_scp.c
> @@ -863,7 +863,9 @@ static void scp_remove_rpmsg_subdev(struct mtk_scp *scp)
> }
>
> static int scp_rproc_init(struct platform_device *pdev,
> - struct mtk_scp_of_regs *of_regs)
> + struct mtk_scp_of_regs *of_regs,
> + const struct mtk_scp_of_data *of_data,
> + bool is_multi_core)

The @is_multi_core variable is a hack and needs to be removed.

> {
> struct device *dev = &pdev->dev;
> struct device_node *np = dev->of_node;
> @@ -884,7 +886,7 @@ static int scp_rproc_init(struct platform_device *pdev,
> scp = (struct mtk_scp *)rproc->priv;
> scp->rproc = rproc;
> scp->dev = dev;
> - scp->data = of_device_get_match_data(dev);
> + scp->data = of_data;
> platform_set_drvdata(pdev, scp);
>
> scp->reg_base = of_regs->reg_base;
> @@ -933,9 +935,11 @@ static int scp_rproc_init(struct platform_device *pdev,
> goto remove_subdev;
> }
>
> - ret = rproc_add(rproc);
> - if (ret)
> - goto remove_subdev;
> + if (!is_multi_core) {
> + ret = rproc_add(rproc);
> + if (ret)
> + goto remove_subdev;
> + }

This is also a hack. The same code should be used to do the initialization of a
remotre processor, whether it is unique or part of a cluster.

>
> return 0;
>
> @@ -951,9 +955,123 @@ static int scp_rproc_init(struct platform_device *pdev,
> return ret;
> }
>
> +static void scp_rproc_free(struct mtk_scp *scp)
> +{
> + int i;
> +
> + scp_remove_rpmsg_subdev(scp);
> + scp_ipi_unregister(scp, SCP_IPI_INIT);
> + scp_unmap_memory_region(scp);
> + for (i = 0; i < SCP_IPI_MAX; i++)
> + mutex_destroy(&scp->ipi_desc[i].lock);
> + mutex_destroy(&scp->send_lock);
> +}
> +
> +static void scp_rproc_exit(struct platform_device *pdev)
> +{
> + struct mtk_scp *scp = platform_get_drvdata(pdev);
> +
> + rproc_del(scp->rproc);
> + scp_rproc_free(scp);
> +}
> +
> +static int scp_cluster_init(struct platform_device *pdev,
> + struct mtk_scp_of_regs *of_regs)
> +{
> + struct device *dev = &pdev->dev;
> + struct device_node *np = dev_of_node(dev);
> + struct platform_device *cpdev;
> + struct device_node *child;
> + const struct mtk_scp_of_data **cluster_of_data;
> + struct list_head *cluster = NULL;
> + struct mtk_scp *scp, *temp;
> + int core_id = 0, num_cores;
> + int ret;
> +
> + cluster_of_data = (const struct mtk_scp_of_data **)of_device_get_match_data(dev);
> +
> + for (num_cores = 0; cluster_of_data[num_cores]; num_cores++)
> + ;

Definitely remove. Either use ARRAY_SIZE() or of_get_available_child_count().

> +
> + for_each_available_child_of_node(np, child) {
> + if (core_id >= num_cores) {
> + ret = -EINVAL;
> + dev_err(dev, "Not support core %d\n", core_id);
> + of_node_put(child);
> + goto init_fail;
> + }
> +
> + cpdev = of_find_device_by_node(child);
> + if (!cpdev) {
> + ret = -ENODEV;
> + dev_err(dev, "Not found platform device for core %d\n", core_id);
> + of_node_put(child);
> + goto init_fail;
> + }
> +
> + ret = scp_rproc_init(cpdev, of_regs, cluster_of_data[core_id], true);
> + if (ret) {
> + dev_err(dev, "Failed to initialize core %d rproc\n", core_id);
> + put_device(&cpdev->dev);
> + of_node_put(child);
> + goto init_fail;
> + }
> +
> + scp = platform_get_drvdata(cpdev);
> + put_device(&cpdev->dev);
> + if (core_id == 0) {
> + INIT_LIST_HEAD(&scp->cluster_cores);
> + cluster = &scp->cluster_cores;
> + platform_set_drvdata(pdev, cluster);
> + }

This should go in scp_probe().

> +
> + list_add_tail(&scp->elem, cluster);
> + scp->cluster = cluster;
> +
> + of_node_put(child);

Is this needed?

> + core_id++;
> + }
> +
> + list_for_each_entry_safe_reverse(scp, temp, cluster, elem) {
> + ret = rproc_add(scp->rproc);

This code is complex and hard to read because rproc_add() is called in two
different context. From a code perspective single core remote processors should
be treated as a one core cluster.

I am done reviewing this patchset.

Thanks,
Mathieu

> + if (ret)
> + goto add_fail;
> + }
> +
> + return 0;
> +
> +add_fail:
> + list_for_each_entry_continue(scp, cluster, elem) {
> + rproc_del(scp->rproc);
> + }
> +init_fail:
> + if (cluster) {
> + list_for_each_entry_safe_reverse(scp, temp, cluster, elem) {
> + list_del(&scp->elem);
> + scp_rproc_free(scp);
> + }
> + }
> + return ret;
> +}
> +
> +static void scp_cluster_exit(struct platform_device *pdev)
> +{
> + struct list_head *cluster = platform_get_drvdata(pdev);
> + struct platform_device *cpdev;
> + struct mtk_scp *scp, *temp;
> +
> + list_for_each_entry_safe_reverse(scp, temp, cluster, elem) {
> + list_del(&scp->elem);
> + cpdev = to_platform_device(scp->dev);
> + scp_rproc_exit(cpdev);
> + }
> +}
> +
> static int scp_probe(struct platform_device *pdev)
> {
> struct device *dev = &pdev->dev;
> + struct device_node *np = dev->of_node;
> + struct device_node *core_node;
> struct resource *res;
> struct mtk_scp_of_regs scp_regs;
> int ret;
> @@ -976,21 +1094,43 @@ static int scp_probe(struct platform_device *pdev)
> scp_regs.l1tcm_phys = res->start;
> }
>
> - return scp_rproc_init(pdev, &scp_regs);
> + ret = devm_of_platform_populate(dev);
> + if (ret)
> + return dev_err_probe(dev, ret, "Failed to populate platform devices\n");
> +
> + core_node = of_get_child_by_name(np, "scp");
> + of_node_put(core_node);

Please use of_get_available_child_count()

> +
> + if (!core_node) {
> + dev_info(dev, "single-core scp\n");
> +
> + ret = scp_rproc_init(pdev, &scp_regs, of_device_get_match_data(dev), false);
> + if (ret)
> + return dev_err_probe(dev, ret, "Failed to initialize single-core scp\n");
> + } else {
> + dev_info(dev, "multi-core scp\n");
> +
> + ret = scp_cluster_init(pdev, &scp_regs);
> + if (ret)
> + return dev_err_probe(dev, ret, "Failed to initialize scp cluster\n");
> + }
> +
> + return 0;
> }
>
> static int scp_remove(struct platform_device *pdev)
> {
> - struct mtk_scp *scp = platform_get_drvdata(pdev);
> - int i;
> + struct device *dev = &pdev->dev;
> + struct device_node *np = dev->of_node;
> + struct device_node *core_node;
>
> - rproc_del(scp->rproc);
> - scp_remove_rpmsg_subdev(scp);
> - scp_ipi_unregister(scp, SCP_IPI_INIT);
> - scp_unmap_memory_region(scp);
> - for (i = 0; i < SCP_IPI_MAX; i++)
> - mutex_destroy(&scp->ipi_desc[i].lock);
> - mutex_destroy(&scp->send_lock);
> + core_node = of_get_child_by_name(np, "scp");
> + of_node_put(core_node);
> +
> + if (!core_node)
> + scp_rproc_exit(pdev);
> + else
> + scp_cluster_exit(pdev);
>
> return 0;
> }
> @@ -1069,12 +1209,19 @@ static const struct mtk_scp_of_data mt8195_of_data_c1 = {
> .host_to_scp_int_bit = MT8195_CORE1_HOST_IPC_INT_BIT,
> };
>
> +static const struct mtk_scp_of_data *mt8195_of_data_cores[] = {
> + &mt8195_of_data,
> + &mt8195_of_data_c1,
> + NULL
> +};
> +
> static const struct of_device_id mtk_scp_of_match[] = {
> { .compatible = "mediatek,mt8183-scp", .data = &mt8183_of_data },
> { .compatible = "mediatek,mt8186-scp", .data = &mt8186_of_data },
> { .compatible = "mediatek,mt8188-scp", .data = &mt8188_of_data },
> { .compatible = "mediatek,mt8192-scp", .data = &mt8192_of_data },
> { .compatible = "mediatek,mt8195-scp", .data = &mt8195_of_data },
> + { .compatible = "mediatek,mt8195-scp-dual", .data = &mt8195_of_data_cores },
> {},
> };
> MODULE_DEVICE_TABLE(of, mtk_scp_of_match);
> --
> 2.18.0
>