Re: [PATCH v4 02/14] dt-bindings: display/msm/gmu: Add GMU wrapper

From: Krzysztof Kozlowski
Date: Thu Mar 16 2023 - 03:10:56 EST


On 14/03/2023 16:28, Konrad Dybcio wrote:
> The "GMU Wrapper" is Qualcomm's name for "let's treat the GPU blocks
> we'd normally assign to the GMU as if they were a part of the GMU, even
> though they are not". It's a (good) software representation of the GMU_CX
> and GMU_GX register spaces within the GPUSS that helps us programatically
> treat these de-facto GMU-less parts in a way that's very similar to their
> GMU-equipped cousins, massively saving up on code duplication.
>
> The "wrapper" register space was specifically designed to mimic the layout
> of a real GMU, though it rather obviously does not have the M3 core et al.
>
> To sum it all up, the GMU wrapper is essentially a register space within
> the GPU, which Linux sees as a dumbed-down regular GMU: there's no clocks,
> interrupts, multiple reg spaces, iommus and OPP. Document it.
>
> Signed-off-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxx>
> ---
> .../devicetree/bindings/display/msm/gmu.yaml | 49 ++++++++++++++++------
> 1 file changed, 37 insertions(+), 12 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/display/msm/gmu.yaml b/Documentation/devicetree/bindings/display/msm/gmu.yaml
> index ab14e81cb050..021373e686e1 100644
> --- a/Documentation/devicetree/bindings/display/msm/gmu.yaml
> +++ b/Documentation/devicetree/bindings/display/msm/gmu.yaml
> @@ -19,16 +19,18 @@ description: |
>
> properties:
> compatible:
> - items:
> - - pattern: '^qcom,adreno-gmu-6[0-9][0-9]\.[0-9]$'
> - - const: qcom,adreno-gmu
> + oneOf:
> + - items:
> + - pattern: '^qcom,adreno-gmu-6[0-9][0-9]\.[0-9]$'
> + - const: qcom,adreno-gmu
> + - const: qcom,adreno-gmu-wrapper
>
> reg:
> - minItems: 3
> + minItems: 1
> maxItems: 4
>
> reg-names:
> - minItems: 3
> + minItems: 1
> maxItems: 4
>
> clocks:
> @@ -44,7 +46,6 @@ properties:
> - description: GMU HFI interrupt
> - description: GMU interrupt
>
> -
> interrupt-names:
> items:
> - const: hfi
> @@ -72,14 +73,8 @@ required:
> - compatible
> - reg
> - reg-names
> - - clocks
> - - clock-names
> - - interrupts
> - - interrupt-names
> - power-domains
> - power-domain-names
> - - iommus
> - - operating-points-v2
>
> additionalProperties: false
>
> @@ -216,6 +211,27 @@ allOf:
> - const: cxo
> - const: axi
> - const: memnoc

Blank line (you added such between ifs in previous patch)

Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxx>

Best regards,
Krzysztof