[PATCH v2 0/5] mm: userfaultfd: refactor and add UFFDIO_CONTINUE_MODE_WP

From: Axel Rasmussen
Date: Wed Feb 22 2023 - 19:58:11 EST


This series, currently based on 6.2, is divided into two parts:

- Commits 1-4 refactor userfaultfd ioctl code without behavior changes, with the
main goal of improving consistency and reducing the number of function args.
- Commit 5 adds UFFDIO_CONTINUE_MODE_WP.

The refactors are sorted by increasing controversial-ness, the idea being we
could drop some of the refactors if they are deemed not worth it.

Changelog:
v1->v2: refactor before adding the new flag, to avoid perpetuating messiness

Axel Rasmussen (5):
mm: userfaultfd: rename functions for clarity + consistency
mm: userfaultfd: don't pass around both mm and vma
mm: userfaultfd: combine 'mode' and 'wp_copy' arguments
mm: userfaultfd: don't separate addr + len arguments
mm: userfaultfd: add UFFDIO_CONTINUE_MODE_WP to install WP PTEs

fs/userfaultfd.c | 121 +++++-------
include/linux/hugetlb.h | 28 ++-
include/linux/shmem_fs.h | 8 +-
include/linux/userfaultfd_k.h | 57 +++---
include/uapi/linux/userfaultfd.h | 7 +
mm/hugetlb.c | 35 ++--
mm/shmem.c | 13 +-
mm/userfaultfd.c | 236 +++++++++++------------
tools/testing/selftests/vm/userfaultfd.c | 4 +
9 files changed, 245 insertions(+), 264 deletions(-)

--
2.39.2.637.g21b0678d19-goog