Re: [PATCH 1/2] io_uring: Move from hlist to io_wq_work_node

From: Jens Axboe
Date: Tue Feb 21 2023 - 18:54:25 EST


On 2/21/23 11:38?AM, Breno Leitao wrote:
> Sure. I will remove the assignents in "if" part and maybe replicate what
> we have
> in io_alloc_cache_get(). Something as:
> if (cache->list.next) {
> node = cache->list.next;
>
> Thanks for the review!

Pavel is right in that we generally discourage assignments in if
statements etc. For the above, the usual approach would be:

node = cache->list.next;
if (node) {
...
}

--
Jens Axboe