[PATCH 10/11] staging: rtl8192e: Remove entry .irq_disable from struct rtl819x_ops

From: Philipp Hortmann
Date: Sun Feb 19 2023 - 16:17:18 EST


Remove entry .irq_disable and replace it with function name
rtl92e_disable_irq. This increases readability of the code.

Signed-off-by: Philipp Hortmann <philipp.g.hortmann@xxxxxxxxx>
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 3 +--
drivers/staging/rtl8192e/rtl8192e/rtl_core.h | 1 -
2 files changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
index 0b6d3b3c6415..978088ab076c 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
@@ -29,7 +29,6 @@ static const struct rtl819x_ops rtl819xp_ops = {
.nic_type = NIC_8192E,
.link_change = rtl92e_link_change,
.rx_command_packet_handler = NULL,
- .irq_disable = rtl92e_disable_irq,
.irq_clear = rtl92e_clear_irq,
.rx_enable = rtl92e_enable_rx,
.tx_enable = rtl92e_enable_tx,
@@ -253,7 +252,7 @@ void rtl92e_irq_disable(struct net_device *dev)
{
struct r8192_priv *priv = rtllib_priv(dev);

- priv->ops->irq_disable(dev);
+ rtl92e_disable_irq(dev);

priv->irq_enabled = 0;
}
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.h b/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
index 6b5761374d54..eb2b1e2ce4a6 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
@@ -210,7 +210,6 @@ struct rtl819x_ops {
bool (*rx_command_packet_handler)(struct net_device *dev,
struct sk_buff *skb,
struct rx_desc *pdesc);
- void (*irq_disable)(struct net_device *dev);
void (*irq_clear)(struct net_device *dev);
void (*rx_enable)(struct net_device *dev);
void (*tx_enable)(struct net_device *dev);
--
2.39.2