Re: [PATCH 08/16] PCI: samsung: Rename exynos_pcie to samsung_pcie

From: Krzysztof Kozlowski
Date: Thu Feb 16 2023 - 06:07:14 EST


On 14/02/2023 13:13, Shradha Todi wrote:
> The platform specific structure being used is named
> exynos_pcie. Changing it to samsung_pcie for making it
> generic.
>
> Suggested-by: Pankaj Dubey <pankaj.dubey@xxxxxxxxxxx>
> Signed-off-by: Shradha Todi <shradha.t@xxxxxxxxxxx>
> ---
> drivers/pci/controller/dwc/pci-samsung.c | 190 +++++++++++------------
> 1 file changed, 95 insertions(+), 95 deletions(-)
>
> diff --git a/drivers/pci/controller/dwc/pci-samsung.c b/drivers/pci/controller/dwc/pci-samsung.c
> index d5adf1017a05..be0177fcd763 100644
> --- a/drivers/pci/controller/dwc/pci-samsung.c
> +++ b/drivers/pci/controller/dwc/pci-samsung.c
> @@ -23,7 +23,7 @@
>
> #include "pcie-designware.h"
>
> -#define to_exynos_pcie(x) dev_get_drvdata((x)->dev)
> +#define to_samsung_pcie(x) dev_get_drvdata((x)->dev)
>
> /* PCIe APPL registers */
> #define EXYNOS_PCIE_IRQ_PULSE 0x000
> @@ -51,7 +51,7 @@
> #define EXYNOS_PCIE_APPL_SLV_ARMISC 0x120
> #define EXYNOS_PCIE_APPL_SLV_DBI_ENABLE BIT(21)
>
> -struct exynos_pcie {
> +struct samsung_pcie {

No, I don't see benefit of this at all. How we call stuff inside driver
is not related whether this is for Tesla or Exynos. We could even call
it "pony". :) Thus renamings just to support new variant of Samsung
device is not a good reason.

Unless all of the old "exynos" names will be soon needed for some
exynos-specific variants?

Best regards,
Krzysztof