Re: [PATCH v6 07/12] remoteproc: mediatek: Probe multi-core SCP

From: TingHan Shen (沈廷翰)
Date: Tue Feb 14 2023 - 22:55:24 EST


On Mon, 2023-02-13 at 15:58 +0100, AngeloGioacchino Del Regno wrote:
> Il 13/02/23 04:37, Tinghan Shen ha scritto:
> > The difference of single-core SCP and multi-core SCP device tree is
> > the presence of child device nodes described SCP cores. The SCP
> > driver populates the platform device and checks the child nodes
> > to identify whether it's a single-core SCP or a multi-core SCP.
> >
> > The resource structure of the multi-core SCP is a list of remoteproc
> > instances which is different to the single-core SCP. The corresponding
> > resource releasing action is based on the type of SCP.
> >
> > Signed-off-by: Tinghan Shen <tinghan.shen@xxxxxxxxxxxx>
> > ---
> > drivers/remoteproc/mtk_common.h | 7 ++
> > drivers/remoteproc/mtk_scp.c | 177 +++++++++++++++++++++++++++++---
> > 2 files changed, 169 insertions(+), 15 deletions(-)
> >
> > diff --git a/drivers/remoteproc/mtk_common.h b/drivers/remoteproc/mtk_common.h
> > index 3778894c96f3..635b17676de8 100644
> > --- a/drivers/remoteproc/mtk_common.h
> > +++ b/drivers/remoteproc/mtk_common.h
> > @@ -112,6 +112,10 @@ struct mtk_scp_of_data {
> > size_t ipi_buf_offset;
> > };
> >
> > +struct mtk_scp_cluster {
> > + struct list_head cores;
>
> You don't need this structure... it's just one element inside, so you can
> simply add it to `struct mtk_scp` instead: for readability purposes, you
> can call this list `cluster_cores`.
>
> After which
>
> Reviewed-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@xxxxxxxxxxxxx>
>
>

No problem, but I feel that this change is not small enough to have your reivew-by tag in the next version.
I would like to have your help to take a look at the next version.


--
Best regards,
TingHan