Re: [PATCH v9 07/18] x86/virt/tdx: Do TDX module per-cpu initialization

From: Peter Zijlstra
Date: Tue Feb 14 2023 - 11:07:19 EST


On Tue, Feb 14, 2023 at 12:02:22AM +0000, Huang, Kai wrote:
> On Mon, 2023-02-13 at 14:43 -0800, Dave Hansen wrote:
> > On 2/13/23 13:19, Huang, Kai wrote:
> > > > On 2/13/23 03:59, Kai Huang wrote:
> > > > > To avoid duplicated code, add a
> > > > > helper to call SEAMCALL on all online cpus one by one but with a skip
> > > > > function to check whether to skip certain cpus, and use that helper to
> > > > > do the per-cpu initialization.
> > > > ...
> > > > > +/*
> > > > > + * Call @func on all online cpus one by one but skip those cpus
> > > > > + * when @skip_func is valid and returns true for them.
> > > > > + */
> > > > > +static int tdx_on_each_cpu_cond(int (*func)(void *), void *func_data,
> > > > > + bool (*skip_func)(int cpu, void *),
> > > > > + void *skip_data)
> > > > I only see one caller of this. Where is the duplicated code?
> > > The other caller is in patch 15 (x86/virt/tdx: Configure global KeyID on all packages).
> > >
> > > I kinda mentioned this in the changelog:
> > >
> > > " Similar to the per-cpu module initialization, a later step to config the key for the global KeyID..."
> > >
> > > If we don't have this helper, then we can end up with having below loop in two functions:
> > >
> > > for_each_online(cpu) {
> > > if (should_skip(cpu))
> > > continue;
> > >
> > > // call @func on @cpu.
> > > }
> >
> > I don't think saving two lines of actual code is worth the opacity that
> > results from this abstraction.
>
> Alright thanks for the suggestion. I'll remove this tdx_on_each_cpu_cond() and
> do directly.
>
> But just checking:
>
> LP.INIT can actually be called in parallel on different cpus (doesn't have to,
> of course), so we can actually just use on_each_cpu_cond() for LP.INIT:
>
> on_each_cpu_cond(should_skip_cpu, smp_func_module_lp_init, NULL, true);
>
> But IIUC Peter doesn't like using IPI and prefers using via work:
>
> https://lore.kernel.org/lkml/Y30dujuXC8wlLwoQ@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/
>
> So I used smp_call_on_cpu() here, which only calls @func on one cpu, but not a
> cpumask. For LP.INIT ideally we can have something like:
>
> schedule_on_cpu(struct cpumask *cpus, work_func_t func);
>
> to call @func on a cpu set, but that doesn't exist now, and I don't think it's
> worth to introduce it?

schedule_on_each_cpu() exists and can easily be extended to take a cond
function if you so please.